AnalyticalPowerDistributableNodeDataSetConnectedPhasesOnDownstream Method

Set the electrical connected phases of the downstream node.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetConnectedPhasesOnDownstream(
	ElementId id,
	ElectricalConnectedPhases connectedPhases
)

Parameters

id  ElementId
The downstream node id.
connectedPhases  ElectricalConnectedPhases
The electrical connected phases to set to the downstream node.
Exceptions
ExceptionCondition
ArgumentException The id isn't a downstream node id of the power distributable node. -or- The electrical connected phases can't be used to connect the downstream node to the power distributable node.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
If node B supplies from node A, node B is the downstream node of node A, and node A is the upstream node of node B. Usually one node may have many downstream nodes, but TransferSwitch can only have one downstream node.
See Also