TableCellStyleOverrideOptions Class

This helper class represents the overridden characteristics of the associated cell.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBTableCellStyleOverrideOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TableCellStyleOverrideOptions : IDisposable

The TableCellStyleOverrideOptions type exposes the following members.

Constructors
 NameDescription
Public methodTableCellStyleOverrideOptions Creates a new instance with no style characteristics overridden.
Public methodTableCellStyleOverrideOptions(TableCellStyleOverrideOptions) Creates a new instance by copying an existing instance.
Top
Properties
 NameDescription
Public propertyBackgroundColor Indicates if the background color characteristic is overridden.
Public propertyBold Indicates if the bold characteristic is overridden.
Public propertyBorderBottomLineStyle Indicates if the border bottom line style characteristic is overridden.
Public propertyBorderLeftLineStyle Indicates if the border left line style characteristic is overridden.
Public propertyBorderLineStyle Indicates if the border line style characteristic is overridden.
Public propertyBorderRightLineStyle Indicates if the border right line style characteristic is overridden.
Public propertyBorderTopLineStyle Indicates if the border top line style characteristic is overridden.
Public propertyFont Indicates if the font name characteristic is overridden.
Public propertyFontColor Indicates if the font color characteristic is overridden.
Public propertyFontSize Indicates if the font size characteristic is overridden.
Public propertyHorizontalAlignment Indicates if the horizontal alignment characteristic is overridden.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyItalics Indicates if the italics characteristic is overridden.
Public propertyTextOrientation Indicates if the text orientation characteristic is overridden.
Public propertyUnderline Indicates if the underline characteristic is overridden.
Public propertyVerticalAlignment Indicates if the vertical alignment characteristic is overridden.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the TableCellStyleOverrideOptions
Public methodSetAllOverrides Sets all overrides to a specific value.
Top
Remarks
The user can override the text appearance and cell graphic properties by setting the corresponding flag to true. The global base format will control the non-overridden characteristics.
See Also