FamilySymbolProfile Class

Represents a family symbol based profile for sweep or swept blend elements.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBSweepProfile
      Autodesk.Revit.DBFamilySymbolProfile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilySymbolProfile : SweepProfile

The FamilySymbolProfile type exposes the following members.

Properties
 NameDescription
Public propertyAngleThe angle of the rotation of the profile in radians.
Public propertyIsFlippedIndicates if the symbol profile is flipped or not.
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyProfileReturns the family symbol of the profile.
Public propertyXOffsetThe offset of the profile to the origin of the sketch plane in the X direction.
Public propertyYOffsetThe offset of the profile to the origin of the sketch plane in the Y direction.
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Use objects of this type in methods as NewSweep() and NewSweptBlend() in FamilyItemFactory to create the profile.
See Also