SteelElementProperties Class

This class is used to attach steel fabrication information to various Revit elements.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DB.SteelSteelElementProperties

Namespace: Autodesk.Revit.DB.Steel
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SteelElementProperties : APIObject

The SteelElementProperties type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyUniqueID This method will return the fabrication id. This represents the link between the Revit and the Steel Core element.
Top
Methods
 NameDescription
Public methodStatic memberAddFabricationInformationForRevitElements This method adds fabrication information to the given elements.
Public methodStatic memberGetFabricationUniqueID This method will return the fabrication id for the given reference.
Public methodStatic memberGetReference This method will return the reference for the given fabrication id.
Public methodStatic memberCode exampleGetSteelElementProperties Get SteelElementProperties for the input element if they exist.
Top
Remarks
Revit elements which can have fabrication information are:
  • FamilyInstance (structural beams and columns).
  • StructuralConnectionHandler elements associated to the connection.
  • Specific steel connection elements (bolts, anchors, plates, etc). These connection elements will be of type element but with categories related to structural connections, for example:
    • OST_StructConnectionWelds
    • OST_StructConnectionHoles
    • OST_StructConnectionModifiers
    • OST_StructConnectionShearStuds
    • OST_StructConnectionBolts
    • OST_StructConnectionAnchors
    • OST_StructConnectionPlates
  • Some concrete elements (walls, floors, concrete beams, ...) when they are input elements to detailed steel connections.
The class also holds the link to the Steel Core elements.
See Also