SteelElementPropertiesGetFabricationUniqueID Method |
This method will return the fabrication id for the given reference.
Namespace: Autodesk.Revit.DB.SteelAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Guid GetFabricationUniqueID(
Document aDoc,
Reference reference
)
Public Shared Function GetFabricationUniqueID (
aDoc As Document,
reference As Reference
) As Guid
public:
static Guid GetFabricationUniqueID(
Document^ aDoc,
Reference^ reference
)
static member GetFabricationUniqueID :
aDoc : Document *
reference : Reference -> Guid
Parameters
- aDoc Document
-
Document to which the reference belongs.
- reference Reference
-
The reference to the element or subelement for which fabrication id is required.
Return Value
Guid
The fabrication id of the element or subelement for this reference, if it has fabrication information attached, or an Guid.Empty otherwise.
Exceptions
See Also