SteelElementPropertiesAddFabricationInformationForRevitElements Method |
This method adds fabrication information to the given elements.
Namespace: Autodesk.Revit.DB.SteelAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<ElementId> AddFabricationInformationForRevitElements(
Document aDoc,
IList<ElementId> elementIds
)
Public Shared Function AddFabricationInformationForRevitElements (
aDoc As Document,
elementIds As IList(Of ElementId)
) As IList(Of ElementId)
public:
static IList<ElementId^>^ AddFabricationInformationForRevitElements(
Document^ aDoc,
IList<ElementId^>^ elementIds
)
static member AddFabricationInformationForRevitElements :
aDoc : Document *
elementIds : IList<ElementId> -> IList<ElementId>
Parameters
- aDoc Document
-
Document containing the given elements ids.
- elementIds IListElementId
-
Ids of the elements to which we want to add fabrication information.
Return Value
IListElementId
Ids of the elements for which we couldn't add fabrication information.
Exceptions
Remarks
You can add fabrication information to connections, beams, columns, braces, walls, floors and foundations.
See Also