HermiteSurface Class

A Hermite Surface.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSurface
    Autodesk.Revit.DBHermiteSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class HermiteSurface : Surface

The HermiteSurface type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Surface)
Public propertyOrientationMatchesParametricOrientation Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation.
(Inherited from Surface)
Top
Methods
 NameDescription
Public methodStatic memberCreate(Int32, Int32, IListXYZ) Create a non-periodic Hermite surface using a net of 3D points as input.
Public methodStatic memberCreate(Int32, Int32, IListXYZ, Boolean, Boolean) Create a Hermite surface using a net of 3D points as input. Specify periodicity in U and V direction.
Public methodDispose
(Inherited from Surface)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetBoundingBoxUV Gets the UV bounding box of the surface.
(Inherited from Surface)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsValid Checks whether this HermiteSurface object is valid.
Public methodProject Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails.
(Inherited from Surface)
Public methodProjectWithGuessPoint Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails.
(Inherited from Surface)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also