HermiteSurface Class

A Hermite Surface.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSurface
    Autodesk.Revit.DBHermiteSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class HermiteSurface : Surface

The HermiteSurface type exposes the following members.

Properties
 NameDescription
Top
Methods
 NameDescription
Public methodStatic memberCreate(Int32, Int32, IListXYZ) Create a non-periodic Hermite surface using a net of 3D points as input.
Public methodStatic memberCreate(Int32, Int32, IListXYZ, Boolean, Boolean) Create a Hermite surface using a net of 3D points as input. Specify periodicity in U and V direction.
Public methodIsValid Checks whether this HermiteSurface object is valid.
Top
See Also