HermiteSurfaceCreate(Int32, Int32, IListXYZ, Boolean, Boolean) Method |
Create a Hermite surface using a net of 3D points as input. Specify periodicity in U and V direction.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static HermiteSurface Create(
int nU,
int nV,
IList<XYZ> points,
bool periodicU,
bool periodicV
)
Public Shared Function Create (
nU As Integer,
nV As Integer,
points As IList(Of XYZ),
periodicU As Boolean,
periodicV As Boolean
) As HermiteSurface
public:
static HermiteSurface^ Create(
int nU,
int nV,
IList<XYZ^>^ points,
bool periodicU,
bool periodicV
)
static member Create :
nU : int *
nV : int *
points : IList<XYZ> *
periodicU : bool *
periodicV : bool -> HermiteSurface
Parameters
- nU Int32
-
Number of points in U direction.
- nV Int32
-
Number of points in V direction.
- points IListXYZ
-
Array of points. Must contain nU*nV points.
- periodicU Boolean
-
Periodicity in U direction
- periodicV Boolean
-
Periodicity in V direction
Return Value
HermiteSurface
A Hermite surface object created from input data.
Exceptions
Remarks
Points form a net of nU * nV (less one each if periodic) 3D points.
See Also