HermiteSurfaceCreate(Int32, Int32, IListXYZ) Method |
Create a non-periodic Hermite surface using a net of 3D points as input.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static HermiteSurface Create(
int nU,
int nV,
IList<XYZ> points
)
Public Shared Function Create (
nU As Integer,
nV As Integer,
points As IList(Of XYZ)
) As HermiteSurface
public:
static HermiteSurface^ Create(
int nU,
int nV,
IList<XYZ^>^ points
)
static member Create :
nU : int *
nV : int *
points : IList<XYZ> -> HermiteSurface
Parameters
- nU Int32
-
Number of points in U direction.
- nV Int32
-
Number of points in V direction.
- points IListXYZ
-
Array of points. Must contain nU*nV points.
Return Value
HermiteSurface
A Hermite surface object created from input data.
Exceptions
Remarks
Points form a net of nU * nV 3D points. Suitable defaults will be used for other surface parameters.
See other Create() functions if greater control over input is desired.
See Also