BuiltInFailuresElectricalFailures Class

Failures about Electricity.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresElectricalFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ElectricalFailures

The BuiltInFailuresElectricalFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberAllSlotsOnPanelOccupied All slots on panel: [Panel Name] are occupied. Some circuits will be disconnected from this panel.
Public propertyStatic memberBankDistanceSmallerThanDiameter The distance value is smaller than the conduit diameter, please enter a larger value
Public propertyStatic memberCableTrayModified The cable tray has been modified to be in the opposite direction or insufficient space to create the required fittings.
Public propertyStatic memberCannotAddMorePolesToCircuit Empty slots are unavailable to hold the number of poles you specified for this spare. \nTo add more poles to this spare, you must free up slots by moving the circuits below the spare.
Public propertyStatic memberCannotAssignSecondaryDistSysToCircuit Cannot assign or add [Element] to Circuit. There is no assigned secondary distribution system for [Element].
Public propertyStatic memberCannotConnectDifferentDesignOptsObjects Cannot add or assign [Element] to circuit. Electrical objects belonging to different design options cannot be connected.
Public propertyStatic memberCannotCreatePanelScheduleDuetoNoDefaultTemplate A panel schedule cannot be created for these panels. A default panel schedule template must be assigned for this template type.
Public propertyStatic memberCannotRemoveMembersInCircuitHavingParent You have selected elements that are connected to a Panel object in a Circuit. These elements cannot be removed from the Circuit.
Public propertyStatic memberCircuitOverload Total connected apparent power for Circuit [Name] is exceeding 80% of the defined rating ([Rating Value]).
Public propertyStatic memberCircuitsOverlapAndDeleteSpareSpace More than one Spare/Space falls onto the same slot. These Spares/Spaces will be deleted.
Public propertyStatic memberCircuitsOverlapDisconnectCircuits More than one circuit falls onto the same slot. These circuits will be disconnected.
Public propertyStatic memberConduitModified The conduit has been modified to be in the opposite direction or insufficient space to create the required fittings.
Public propertyStatic memberElementsBelongToOtherCircuit You have selected elements that are already part of other Circuits that have assigned Panels. The elements you selected cannot be added to this Circuit.
Public propertyStatic memberFamilyMismatchCircuit The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?
Public propertyStatic memberFeedThroughLugsIsDisabled The feed through lugs option is unchecked.
Public propertyStatic memberFeedThroughLugsIsNotEnabledAndBindFormulaInFamily Can't change connection type to Feed Through Lugs because Feed Through Lugs is unchecked. Enable Feed Through Lugs with related formula in family editor the Feed Through Lugs is mapped to. Select the panel -> Edit Family -> Family Types.
Public propertyStatic memberFeedThroughLugsIsNotEnabledAndBindGlobalParam Can't change connection type to Feed Through Lugs because Feed Through Lugs is not enabled. Enable Feed Through Lugs by enabling the global parameter that Feed Through Lugs is mapping. Click Manage tab -> Settings panel -> Global Parameters.
Public propertyStatic memberFeedThroughLugsIsOccupied The feed through lugs is in use by circuit [Element].
Public propertyStatic memberFeedThroughLugsIsOccupiedAndDisconnectOtherCircuits The feed through lugs is occupied, so other circuits connected with feed through lugs will be disconnected from this panel [Panel Name].
Public propertyStatic memberInvalidApparentPowerDensity The Apparent Power Density is invalid. Edit the Power Density and/or Power Factor to recalculate the Apparent Power Density.
Public propertyStatic memberInvalidNumberOfCircuitValueForDataPanel The number of circuits on the data panel currently exceeds the value you entered for Maximum Amount of Circuits parameter. Reduce the number of circuits on the equipment before changing this value.
Public propertyStatic memberInvalidNumberOfCircuitValueForSwitchPanel The number of circuits on the switchboard currently exceeds the value you entered. Reduce the number of circuits on the equipment before changing this value.
Public propertyStatic memberInvalidNumwiresSinglephase Invalid number of wires for single phase, only 2 and 3 are valid.
Public propertyStatic memberInvalidPathOfParallelConduits Invalid path of parallel conduits
Public propertyStatic memberMaximumNumberOfPolesExceeded You cannot add more poles to this spare, as doing so would exceed the maximum number of poles set for this equipment.
Public propertyStatic memberMismatchConnectorDistSysToCircuit Cannot add [Element] to Circuit. The Type for the available connector does not match the Type ([Name]) for the Circuit.
Public propertyStatic memberMismatchDistributionSystem [Name1] and [Name2] cannot connect with each other due to mismatched voltage or number of phases.
Public propertyStatic memberMismatchNmbAssignedDistSysToCircuit Cannot assign or add [Element] to Circuit. There is no assigned distribution system for [Element].
Public propertyStatic memberMismatchNmbOfPolesToCircuit Cannot add [Element] to Circuit. The Number of Poles for [Element] does not match the Number of Poles ([Name]) for the Circuit.
Public propertyStatic memberMismatchPoleBrakesSlotsNumbers The number of pole breakers may not be less than the number of occupied slots.
Public propertyStatic memberMismatchVoltageLineToLine Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Line Voltage for [Element] (The Line to Line Voltage is specified in the assigned Distribution System).
Public propertyStatic memberMismatchVoltageToCircuit Cannot add [Element] to Circuit. The Voltage for [Element] is out of range for the Voltage ([Voltage Value]) for the Circuit.
Public propertyStatic memberMissingOrInvalidWireSizeTable Wire Size Table "[Fail Name]" is missing or invalid. Use Electrical Settings to select a valid Wire Size Table.
Public propertyStatic memberNoAvailableMatchingConnector Cannot add [Element] to Circuit. There is no available connector matching the Type ([Type Name]) for the Circuit.
Public propertyStatic memberNoDistributionSystem The distribution system of [CategoryName] [Name] is set to None. Assign a distribution system.
Public propertyStatic memberNotAllowedCableTrayConduitRotation Don't allow to rotate a horizontal cable tray/conduit like this
Public propertyStatic memberNotEnoughAvailSlotsAndLugsOnPanel You can't connect to panel [Panel Name] because there aren't enough slots and Feed Through Lugs is occupied. \nYou can increase the [ParameterName] to be greater than [Number] to connect through breaker slots or you can disconnect existing Feed Through Lugs connection.
Public propertyStatic memberNotEnoughAvailSlotsAndLugsOnSwitchPanel You can't connect to switchboard [Panel Name] because there aren't enough space and circuit [Circuit Name] is set to Feed Through Lugs. \nYou can increase the number of circuits to be greater than [Number] to connect through breakers or you can disconnect circuit and select Feed Through Lugs again.
Public propertyStatic memberNotEnoughAvailSlotsOnDataPanel You can't connect to data panel [Panel Name] because there isn't enough space \nYou can increase the number of circuits to be greater than [Number].
Public propertyStatic memberNotEnoughAvailSlotsOnPanel You can't change the connection type to Breakers connect to panel [Panel Name] because there aren't enough slots. \nYou can increase the [ParameterName] to be greater than [Number] to connect through breaker slots or open the panel schedule and manually reshuffle non - consecutive slots.
Public propertyStatic memberNotEnoughRoomForParallelConduits Due to changes in elevation, there is not enough room to generate all of the parallel conduits. As a result, some conduit segments have not been generated.
Public propertyStatic memberNotEnoughRoomForParallelPipes Due to changes in elevation, there is not enough room to generate all of the parallel pipes. As a result, some pipe segments have not been generated.
Public propertyStatic memberNotEnoughSlotsOnlyLugAvailable There aren't enough slots on panel [Panel Name], so the circuit will connect through Feed Through Lugs.
Public propertyStatic memberNotEnoughSlotsOnlyLugAvailableForSwitchPanel There aren't enough space on switchboard [Panel Name], so the circuit will connect through Feed Through Lugs.
Public propertyStatic memberNotPositiveBendRadius The value you entered for the bend radius is zero or a negative value. Enter a positive value.
Public propertyStatic memberNotSupportConcentricBend Conduit with Fittings do not support Concentric Bend Radius, the bend radius of the conduit fittings will be same.
Public propertyStatic memberNumberOfCircuitFullOnSwitchPanel You can't change the connection type to Breakers and connect to switchboard [Panel Name] because there aren't enough space. \nYou can increase the number of circuits to be greater than [Number] to connect through breakers.
Public propertyStatic memberObjsDemolished Cannot assign [Element] to circuit. Objects that are demolished cannot be added to a circuit.
Public propertyStatic memberPanelMismatchCircuitType Cannot assign [Element] to Circuit. The Type for the panel does not match the Type ([Name]) for the Circuit.
Public propertyStatic memberPanelMismatchDistSysWhenCircuitAssigned The selected circuit was added to panel [Element], but the distribution system for the panel does not match the power connector definition on the panel.
Public propertyStatic memberPrimaryNumOfPhasesNotEqualWithSecondary Number of Phases of the primary distribution system isn't equal with the secondary distribution system's
Public propertyStatic memberReplaceSpareSpaceOnPanelBoard Need to replace spare or space on panelboard.
Public propertyStatic memberReplaceSpareSpaceOnSwitchBoard Need to replace spare or space on switchboard.
Public propertyStatic memberSecondaryNumOfPhasesNotEqualWithPrimary Number of Phases of the secondary distribution system isn't equal with the primary distribution system's
Public propertyStatic memberSelectedElementsArePartOfOtherCircuit You have selected elements that are already part of other Circuits. They will be removed from the original Circuits and added to this one.
Public propertyStatic memberSmallBendRadius The value you entered for the bend radius for conduit is too small. Enter a larger value.
Public propertyStatic memberTransformerNoDistributionSystem At least one of the distribution systems of Electrical Analytical Transformer [Name] is set to None. Assign distribution systems to the transformer.
Public propertyStatic memberUnsignedCircuit Circuit is not assigned to a panel
Public propertyStatic memberUnsupportedTransformerPrimaryDS [Distribution System Name] cannot appear on the primary side of the transformer.
Public propertyStatic memberVoltageIsOutOfRange Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Ground Voltage for [Element] (The Line to Ground Voltage is specified in the assigned Distribution System)."
Public propertyStatic memberWireMaxSizeNonexistent Cannot find max size in current wire type's material table.
Top
See Also