City Class

An object that contains geographical location information for a known city.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBCity

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class City : APIObject

The City type exposes the following members.

Properties
 NameDescription
Public propertyLatitudeLatitude of the city
Public propertyLongitudeLongitude of the city
Public propertyNameThe name of the city
Public propertyTimeZoneTime-zone in which the city resides
Public propertyWeatherStationAn identifier for the nearest weather station
Top
Methods
 NameDescription
Top
Remarks
This object contains longitude, latitude, time zone information for a city already known by Revit. Currently Revit does not the ability to add cities to the existing list. The list of known cities can be retrieved using the Cities property on the application object.
Example
double angleRatio = Math.PI / 180;   // ratio of Angle

// Get the Latitude information
double latiude = city.Latitude / angleRatio;
String latiudeInfo = "Latitude:      " + latiude.ToString();

// Get the Longitude information
double longitude = city.Longitude / angleRatio;
String longitudeInfo = "Longitude:   " + longitude.ToString();

// Get the TimeZone information
String timeZoneInfo = "TimeZone:   " + city.TimeZone.ToString();

// Set the information text box.
string cityInfo = latiudeInfo + "\n" + longitudeInfo
                            + "\n" + timeZoneInfo;
See Also