CanExecuteEventArgs Class

The event arguments used by AddInCommandBinding's CanExecute event.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitEventArgs
      Autodesk.Revit.UI.EventsCommandEventArgs
        Autodesk.Revit.UI.EventsCanExecuteEventArgs

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CanExecuteEventArgs : CommandEventArgs

The CanExecuteEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyCanExecuteThe value that indicates whether the Command associated with this event can be executed.
Public propertyIsCheckedThe value that indicates whether the UI associated with the Command associated with this event is in a checked state.
Top
Methods
 NameDescription
Public methodGetSelectedCategoryIdsGets the category ids of selected elements.
Top
See Also