CanExecuteEventArgs Class

The event arguments used by AddInCommandBinding's CanExecute event.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitEventArgs
      Autodesk.Revit.UI.EventsCommandEventArgs
        Autodesk.Revit.UI.EventsCanExecuteEventArgs

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CanExecuteEventArgs : CommandEventArgs

The CanExecuteEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyActiveDocument The active document.
(Inherited from CommandEventArgs)
Public propertyCancel Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it.
(Inherited from RevitEventArgs)
Public propertyCancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitEventArgs)
Public propertyCanExecuteThe value that indicates whether the Command associated with this event can be executed.
Public propertyCommandId The command id.
(Inherited from CommandEventArgs)
Public propertyIsCheckedThe value that indicates whether the UI associated with the Command associated with this event is in a checked state.
Top
Methods
 NameDescription
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetSelectedCategoryIdsGets the category ids of selected elements.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also