RevitEventArgs Class

The class is used as base class for all event argument classes.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RevitEventArgs : EventArgs

The RevitEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyCancel Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it.
Public propertyCancellable Indicates whether an event may be cancelled by an event delegate.
Top
Methods
 NameDescription
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also