RevitEventArgsCancellable Property |
Indicates whether an event may be cancelled by an event delegate.
Namespace: Autodesk.Revit.DB.EventsAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic virtual bool Cancellable { get; }
Public Overridable ReadOnly Property Cancellable As Boolean
Get
public:
virtual property bool Cancellable {
bool get ();
}
abstract Cancellable : bool with get
override Cancellable : bool with get
Property Value
Boolean
Remarks
If 'Cancellable' is true, event delegates may cancel the command that
was announced by the event. To do so, a delegate would set the 'Cancel' property to True.
Typically, post-events (e.g. DocumentPrinted) are not cancellable,
while most pre-events (e.g. DocumentPrinting) are cancellable, except for special
conditions and situations, such as when the Revit application is being closed
or if an event is raised during another event.
See Also