DockablePaneState Class

Describes where a dockable pane window should appear in the Revit user interface.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIDockablePaneState

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DockablePaneState : IDisposable

The DockablePaneState type exposes the following members.

Constructors
 NameDescription
Public methodDockablePaneState Creates a new DockablePaneState object.
Public methodDockablePaneState(DockablePaneState) Constructs a new copy of the input DockablePaneState object.
Top
Properties
 NameDescription
Public propertyDockPosition Which part of the Revit application frame the pane should dock to.
Public propertyFloatingRectangle When %dockPosition% is Floating, this rectangle determines the size and position of the pane. Coordinates are relative to the upper-left-hand corner of the main Revit window. Note: the returned Rectangle is a copy. In order to change the pane state, you must call SetFloatingRectangle with a modified rectangle.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyMinimumHeight When %dockPosition% is anything other than floating, the minimum height to use for the pane. Default is 200 pixels.
Public propertyMinimumWidth When %dockPosition% is anything other than floating, the minimum width to use for the pane. Default is 200 pixels.
Public propertyTabBehind Ignored unless %dockPosition% is Tabbed. The new pane will appear in a tab behind the specified existing pane ID.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the DockablePaneState
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetFloatingRectangle When %dockPosition% is Floating, sets the rectangle used to determine the size and position of the pane when %dockPosition% is Floating. Coordinates are relative to the upper-left-hand corner of the main Revit window.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also