BeforeExecutedEventArgs Class

The event arguments used by AddInCommandBinding's BeforeExecuted event.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitEventArgs
      Autodesk.Revit.UI.EventsCommandEventArgs
        Autodesk.Revit.UI.EventsBeforeExecutedEventArgs

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BeforeExecutedEventArgs : CommandEventArgs

The BeforeExecutedEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyActiveDocument The active document.
(Inherited from CommandEventArgs)
Public propertyCancel Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it.
(Inherited from RevitEventArgs)
Public propertyCancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitEventArgs)
Public propertyCommandId The command id.
(Inherited from CommandEventArgs)
Public propertyUsingCommandData Indicates whether or not the Revit journal will include custom data populated by the application associated with this command.
Top
Methods
 NameDescription
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This event is cancellable. If your callback sets the Cancel property to true, the command will not execute.
See Also