ToggleButtonData Class

This class contains information necessary to construct a toggle button in a RadioButtonGroup.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIItemData
    Autodesk.Revit.UIRibbonItemData
      Autodesk.Revit.UIButtonData
        Autodesk.Revit.UIPushButtonData
          Autodesk.Revit.UIToggleButtonData

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ToggleButtonData : PushButtonData

The ToggleButtonData type exposes the following members.

Constructors
 NameDescription
Public methodToggleButtonData(String, String)Constructs a new instance of ToggleButtonData, where the ToggleButton will not be associated to an ExternalCommand.
Public methodToggleButtonData(String, String, String, String)Constructs a new instance of ToggleButtonData, where the ToggleButton will execute an ExternalCommand when clicked.
Top
Properties
 NameDescription
Top
Methods
 NameDescription
Top
See Also