ToggleButtonData Class

This class contains information necessary to construct a toggle button in a RadioButtonGroup.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIItemData
    Autodesk.Revit.UIRibbonItemData
      Autodesk.Revit.UIButtonData
        Autodesk.Revit.UIPushButtonData
          Autodesk.Revit.UIToggleButtonData

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ToggleButtonData : PushButtonData

The ToggleButtonData type exposes the following members.

Constructors
 NameDescription
Public methodToggleButtonData(String, String)Constructs a new instance of ToggleButtonData, where the ToggleButton will not be associated to an ExternalCommand.
Public methodToggleButtonData(String, String, String, String)Constructs a new instance of ToggleButtonData, where the ToggleButton will execute an ExternalCommand when clicked.
Top
Properties
 NameDescription
Public propertyAssemblyNameThe assembly path of the button.
(Inherited from PushButtonData)
Public propertyAvailabilityClassNameThe full class name for the class providing the entry point to decide availability of this push button.
(Inherited from PushButtonData)
Public propertyClassNameThe name of the class containing the implementation for the command.
(Inherited from PushButtonData)
Public propertyImageThe image of the button.
(Inherited from ButtonData)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ItemData)
Public propertyLargeImageThe large image of the button.
(Inherited from ButtonData)
Public propertyLongDescription Long description of the command tooltip
(Inherited from RibbonItemData)
Public propertyName The internal name of the item.
(Inherited from ItemData)
Public propertyTextThe user-visible text of the button.
(Inherited from ButtonData)
Public propertyToolTip The tooltip of item.
(Inherited from ItemData)
Public propertyToolTipImageThe image to show as a part of the button extended tooltip
(Inherited from RibbonItemData)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ItemData)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetContextualHelpGets the contextual help bound with this control.
(Inherited from RibbonItemData)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetContextualHelpSets the contextual help bound with this button data.
(Inherited from RibbonItemData)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also