ElementCategoryFilter Class

A filter used to match elements by their category.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementQuickFilter
      Autodesk.Revit.DBElementCategoryFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementCategoryFilter : ElementQuickFilter

The ElementCategoryFilter type exposes the following members.

Constructors
 NameDescription
Public methodElementCategoryFilter(BuiltInCategory) Constructs a new instance of a filter to match elements by category.
Public methodElementCategoryFilter(ElementId) Constructs a new instance of a filter to match elements by category.
Public methodElementCategoryFilter(BuiltInCategory, Boolean) Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category.
Public methodElementCategoryFilter(ElementId, Boolean) Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.
Top
Properties
 NameDescription
Public propertyCategoryId The category id.
Top
Methods
 NameDescription
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
Example
// Find all Wall instances in the document by using category filter
ElementCategoryFilter filter = new ElementCategoryFilter(BuiltInCategory.OST_Walls);

// Apply the filter to the elements in the active document,
// Use shortcut WhereElementIsNotElementType() to find wall instances only
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> walls = collector.WherePasses(filter).WhereElementIsNotElementType().ToElements();
String prompt = "The walls in the current document are:\n";
foreach (Element e in walls)
{
    prompt += e.Name + "\n";
}
TaskDialog.Show("Revit", prompt);
See Also