ElementCategoryFilter(ElementId, Boolean) Constructor |
Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementCategoryFilter(
ElementId categoryId,
bool inverted
)
Public Sub New (
categoryId As ElementId,
inverted As Boolean
)
public:
ElementCategoryFilter(
ElementId^ categoryId,
bool inverted
)
new :
categoryId : ElementId *
inverted : bool -> ElementCategoryFilter
Parameters
- categoryId ElementId
-
The category id to match.
- inverted Boolean
-
True if the filter should match all elements which are not of the given category.
Exceptions
See Also