ElementFilterPassesFilter(Document, ElementId) Method

Applies the filter to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool PassesFilter(
	Document document,
	ElementId id
)

Parameters

document  Document
The document.
id  ElementId
The element id.

Return Value

Boolean
True if the element is accepted by the filter. False if the element is rejected.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also