ElementCategoryFilter(BuiltInCategory, Boolean) Constructor |
Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementCategoryFilter(
BuiltInCategory category,
bool inverted
)
Public Sub New (
category As BuiltInCategory,
inverted As Boolean
)
public:
ElementCategoryFilter(
BuiltInCategory category,
bool inverted
)
new :
category : BuiltInCategory *
inverted : bool -> ElementCategoryFilter
Parameters
- category BuiltInCategory
-
The category to match.
- inverted Boolean
-
True if the filter should match all elements which are not of the given category.
See Also