AssetPropertyFloatArray Class

Represents a property consisting of an array of float values.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.VisualAssetProperty
    Autodesk.Revit.DB.VisualAssetPropertyFloatArray

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AssetPropertyFloatArray : AssetProperty

The AssetPropertyFloatArray type exposes the following members.

Properties
 NameDescription
Public propertyIsReadOnly Identifies if the object is read-only or modifiable. If true, the object may not be modified. If false, the object's contents may be modified.
(Inherited from AssetProperty)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from AssetProperty)
Public propertyNameGet the name of the AssetProperty
(Inherited from AssetProperty)
Public propertyNumberOfConnectedProperties The number of currently connected properties.
(Inherited from AssetProperty)
Public propertyTypeReturns the type of the AssetProperty
(Inherited from AssetProperty)
Top
Methods
 NameDescription
Public methodAddConnectedAsset Adds a new connected asset attached to this asset property, if it allows it.
(Inherited from AssetProperty)
Public methodCode exampleAddCopyAsConnectedAsset Makes a copy of the asset and connects it to this property.
(Inherited from AssetProperty)
Public methodDispose
(Inherited from AssetProperty)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetAllConnectedProperties Gets the list of the connected properties. Connected properties are the detachable properties of an AssetProperty. e.g. diffuse property can have texture as its connected property. It can also detach texture on runtime.
(Inherited from AssetProperty)
Public methodGetConnectedProperty Gets one connected property with specified index.
(Inherited from AssetProperty)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodCode exampleGetSingleConnectedAsset Gets the single connected asset attached to this asset property, if it exists.
(Inherited from AssetProperty)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodGetValueGet the value of the property.
Public methodIsEditable Check if property can be edited.
(Inherited from AssetProperty)
Public methodIsValidSchemaIdentifier Check that schema name is valid
(Inherited from AssetProperty)
Public methodRemoveConnectedAsset Removes the connected asset attached to this asset property if any.
(Inherited from AssetProperty)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
In virtually all cases, the array will contain exactly 3 values.
See Also