PulldownButtonData Class

This class contains information necessary to construct a pulldown button in the Ribbon.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIItemData
    Autodesk.Revit.UIRibbonItemData
      Autodesk.Revit.UIButtonData
        Autodesk.Revit.UIPulldownButtonData
          Autodesk.Revit.UISplitButtonData

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PulldownButtonData : ButtonData

The PulldownButtonData type exposes the following members.

Constructors
 NameDescription
Public methodPulldownButtonDataConstructs a new instance of PulldownButtonData.
Top
Properties
 NameDescription
Top
Methods
 NameDescription
Top
See Also