ElementTypeDuplicatedEventArgs Class

The event arguments used by the ElementTypeDuplicated event.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitAPIEventArgs
      Autodesk.Revit.DB.EventsRevitAPIPostEventArgs
        Autodesk.Revit.DB.EventsRevitAPIPostDocEventArgs
          Autodesk.Revit.DB.EventsElementTypeDuplicatedEventArgs

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementTypeDuplicatedEventArgs : RevitAPIPostDocEventArgs

The ElementTypeDuplicatedEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyCancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitAPIEventArgs)
Public propertyDocument The document associated with the event.
(Inherited from RevitAPIPostDocEventArgs)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RevitAPIEventArgs)
Public propertyNewElementTypeId The id of the newly duplicated ElementType.
Public propertyNewName The name of the newly duplicated ElementType.
Public propertyOriginalElementTypeId The id of the element type that is duplicated.
Public propertyStatus Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler).
(Inherited from RevitAPIPostEventArgs)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from RevitAPIEventArgs)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsCancelled Indicates whether the event is being cancelled.
(Inherited from RevitAPIEventArgs)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also