ElementTypeDuplicatedEventArgs Class

The event arguments used by the ElementTypeDuplicated event.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitAPIEventArgs
      Autodesk.Revit.DB.EventsRevitAPIPostEventArgs
        Autodesk.Revit.DB.EventsRevitAPIPostDocEventArgs
          Autodesk.Revit.DB.EventsElementTypeDuplicatedEventArgs

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementTypeDuplicatedEventArgs : RevitAPIPostDocEventArgs

The ElementTypeDuplicatedEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyNewElementTypeId The id of the newly duplicated ElementType.
Public propertyNewName The name of the newly duplicated ElementType.
Public propertyOriginalElementTypeId The id of the element type that is duplicated.
Top
Methods
 NameDescription
Top
See Also