NurbsSurfaceData Class

A class used to represent the definition of a NURBS surface.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBNurbsSurfaceData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class NurbsSurfaceData : IDisposable

The NurbsSurfaceData type exposes the following members.

Constructors
 NameDescription
Public methodNurbsSurfaceData Copy constructor.
Top
Properties
 NameDescription
Public propertyDegreeU The degree of the spline in the u-direction.
Public propertyDegreeV The degree of the spline in the v-direction.
Public propertyIsRational Tells if the spline is rational or not. If it is true (rational), then the NURBS is a piecewise rational polynomial function. If it is false (non-rational), then the NURBS is a piecewise polynomial function.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyReverseOrientation If true, the surface's orientation is opposite to the canonical parametric orientation, otherwise it is the same. The canonical parametric orientation is a counter-clockwise sense of rotation in the uv-parameter plane. Extrinsically, the oriented normal vector for the canonical parametric orientation points in the direction of the cross product dS/du x dS/dv, which S(u, v) is the parameterized surface.
Top
Methods
 NameDescription
Public methodStatic memberCreate Construct NurbsSurfaceData based on NURBS surface data, where the weights are supplied. The NURBS surface will be (piecewise) polynomial if all the weights are equal, rational if not. Note: A rational polynomial is a quotient of two polynomials; this includes a polynomial, which can be thought of as a quotient with denominator equal to 1.
Public methodDisposeReleases all resources used by the NurbsSurfaceData
Public methodGetControlPoints Get the list of control points.
Public methodGetKnotsU Get the list of knots in the u-direction.
Public methodGetKnotsV Get the list of knots in the v-direction.
Public methodGetWeights Get the list of weights.
Public methodIsValid Check if the object contains a valid NurbsSurfaceData.
Top
See Also