ScheduleSortGroupField Class

A field that is used for sorting and/or grouping in a schedule.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBScheduleSortGroupField

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ScheduleSortGroupField : IDisposable

The ScheduleSortGroupField type exposes the following members.

Constructors
 NameDescription
Public methodScheduleSortGroupField Creates a new ScheduleSortGroupField.
Public methodScheduleSortGroupField(ScheduleFieldId) Creates a new ScheduleSortGroupField.
Public methodScheduleSortGroupField(ScheduleFieldId, ScheduleSortOrder) Creates a new ScheduleSortGroupField.
Top
Properties
 NameDescription
Public propertyFieldId The ID of the field that the schedule will be sorted or grouped by.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyShowBlankLine Indicates if an empty row should be displayed between groups.
Public propertyShowFooter Indicates if a footer row should be displayed after each group.
Public propertyShowFooterCount Indicates if the footer row should display a count of elements in the group.
Public propertyShowFooterTitle Indicates if the footer row should display a title.
Public propertyShowHeader Indicates if a header row should be displayed before each group.
Public propertySortOrder Indicates if elements in the schedule will be sorted in ascending or descending order.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ScheduleSortGroupField
Top
Remarks

A schedule may be sorted or grouped by one or more of the schedule's fields. The ScheduleSortGroupField class represents one of the fields that the schedule is sorted or grouped by.

Sorting and grouping are related operations. In either case, elements appearing in the schedule are sorted based on their values for the field that the schedule is sorted/grouped by, which automatically causes elements with identical values to be grouped together. By enabling extra header, footer, or blank rows, visual separation between groups can be achieved.

If ScheduleDefinition.IsItemized is false, elements having the same values for all of the fields used for sorting/grouping will be combined onto the same row.

A schedule can be sorted or grouped by data that is not displayed in the schedule by marking the field used for sorting/grouping as hidden using the ScheduleField.IsHidden property.

See Also