WireTypeSet Class

A set that contains wire types.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DB.ElectricalWireTypeSet

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WireTypeSet : APIObject, 
	IEnumerable

The WireTypeSet type exposes the following members.

Constructors
 NameDescription
Public methodWireTypeSetInitializes a new instance of the WireTypeSet class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the set is empty.
Public propertySizeReturns the number of wire types that are in the set.
Top
Methods
 NameDescription
Public methodClearRemoves every wire type from the set, rendering it empty.
Public methodContainsTests for the existence of a wire type within the set.
Public methodEraseRemoves a specified wire type from the set.
Public methodForwardIteratorRetrieve a forward moving iterator to the set.
Public methodGetEnumeratorRetrieve a forward moving iterator to the set.
Public methodInsertInsert the specified wire type into the set.
Public methodReverseIteratorRetrieve a backward moving iterator to the set.
Top
See Also