DockablePaneProviderData Class

Information about a new dockable pane being added to the Revit user interface.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIDockablePaneProviderData

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DockablePaneProviderData

The DockablePaneProviderData type exposes the following members.

Constructors
 NameDescription
Public methodDockablePaneProviderDataInitializes a new instance of the DockablePaneProviderData class
Top
Properties
 NameDescription
Public propertyContextualHelp The contextual help associated with the pane.
Public propertyEditorInteraction Defines the interaction this pane has with the Active Editor when the pane becomes active.
Public propertyFrameworkElement The Windows Presentation Framework object containing the pane's user interface.
Public propertyFrameworkElementCreator A creator that will be called for the pane if the FrameworkElement is not set.
Public propertyInitialState The initial position of the docking pane.
Public propertyVisibleByDefault Controls the default visibility of the pane upon the first time the pane/plugin is loaded into Revit.
Top
Methods
 NameDescription
Public methodGetFrameworkElement Wrapper function that returns the FrameworkElement for this provider.
Top
See Also