DockablePaneProviderDataFrameworkElement Property |
The Windows Presentation Framework object containing the pane's user interface.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FrameworkElement FrameworkElement { get; set; }
Public Property FrameworkElement As FrameworkElement
Get
Set
public:
property FrameworkElement^ FrameworkElement {
FrameworkElement^ get ();
void set (FrameworkElement^ value);
}
member FrameworkElement : FrameworkElement with get, set
Property Value
FrameworkElement
Remarks
Using a System.Windows.Controls.Page is recommended. This can be null, in which case
it is assumed an IFrameworkElementCreator is provided to create the element on demand.
See Also