DockablePaneProviderDataVisibleByDefault Property |
Controls the default visibility of the pane upon the first time
the pane/plugin is loaded into Revit.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool VisibleByDefault { get; set; }
Public Property VisibleByDefault As Boolean
Get
Set
public:
property bool VisibleByDefault {
bool get ();
void set (bool value);
}
member VisibleByDefault : bool with get, set
Property Value
Boolean
Remarks
By default, panes will be created and shown in the Revit UI when
Revit is launched for the first time. Subsequent loads of the Revit
UI will determine the visibility of the panes based upon there state
at the close of the previous Revit session. Providers can set this
to false if they wish there panes to NOT be shown by default.
See Also