DockablePaneProviderDataGetFrameworkElement Method |
Wrapper function that returns the FrameworkElement for this provider.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FrameworkElement GetFrameworkElement()
Public Function GetFrameworkElement As FrameworkElement
public:
FrameworkElement^ GetFrameworkElement()
member GetFrameworkElement : unit -> FrameworkElement
Return Value
FrameworkElement
FrameworkElement to use as the pane's user interface.
Remarks
If an IFrameworkElementCreator is provided, that will be called to generate the element,
otherwise, the FrameworkElement associated with the provider is returned.
See Also