ExternalFileReference Class

A class that contains the details of a reference to a file outside of a given document.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExternalFileReference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalFileReference : IDisposable

The ExternalFileReference type exposes the following members.

Properties
 NameDescription
Public propertyExternalFileReferenceType The type of external file which this object references.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyPathType The path type of the link (relative, absolute, or server).
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ExternalFileReference
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetAbsolutePath Returns an absolute path to the referenced file, regardless of whether the PathType.Enum is relative or absolute.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetLinkedFileStatus Returns a LinkedFileStatus.Enum corresponding to the load status of the referenced file.
Public methodGetPath Gets the path of the link, relative or absolute according to the link's settings
Public methodGetReferencingId Gets the ElementId corresponding to the element which this ExternalFileReference is associated with.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodStatic memberIsValidExternalFileReference Checks an ExternalFileReference to see if it is properly created.
Public methodIsValidPathTypeForExternalFileReference Checks whether a PathType enum value will be valid to use with this ExternalFileReference.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also