ExternalFileReferenceIsValidPathTypeForExternalFileReference Method

Checks whether a PathType enum value will be valid to use with this ExternalFileReference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidPathTypeForExternalFileReference(
	PathType pathType
)

Parameters

pathType  PathType
 

Return Value

Boolean
Exceptions
ExceptionCondition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
  • PathType.Server is only valid for ExternalFileReferences of type ExternalFileReferenceType.RevitLink
  • PathType.Content is only valid for ExternalFileReferences of type ExternalFileReferenceType.KeynoteTable, ExternalFileReferenceType.AssemblyCodeTable and ExternalFileReferenceType.Decal
See Also