ExternalFileReferenceIsValidExternalFileReference Method |
Checks an ExternalFileReference to see if it is
properly created.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidExternalFileReference(
ExternalFileReference data
)
Public Shared Function IsValidExternalFileReference (
data As ExternalFileReference
) As Boolean
public:
static bool IsValidExternalFileReference(
ExternalFileReference^ data
)
static member IsValidExternalFileReference :
data : ExternalFileReference -> bool
Parameters
- data ExternalFileReference
-
The ExternalFileReference to be checked
Return Value
Boolean
Exceptions
Remarks
The following restrictions exist:
- PathType.Server is only valid for ExternalFileReferences of type ExternalFileReferenceType.RevitLink
- PathType.Content is only valid for ExternalFileReferences of type ExternalFileReferenceType.KeynoteTable,
ExternalFileReferenceType.AssemblyCodeTable or ExternalFileReferenceType.Decal
- Keynote tables, assembly code tables and Decals (ExternalFileReferenceType.KeynoteTable,
ExternalFileReferenceType.AssemblyCodeTable and ExternalFileReferenceType.Decal) may only be
LinkedFileStatus.Loaded or LinkedFileStatus.NotFound.
See Also