FilterDoubleRule Class

A filter rule that operates on double-precision numeric values in a Revit project.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterDoubleRule : FilterNumericValueRule

The FilterDoubleRule type exposes the following members.

Constructors
 NameDescription
Public methodFilterDoubleRule Constructs an instance of FilterDoubleRule.
Top
Properties
 NameDescription
Public propertyEpsilon The tolerance within which two floating-point values may be considered equal.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterRule)
Public propertyRuleValue The user-supplied value against which values from a Revit document will be tested.
Top
Methods
 NameDescription
Public methodDispose
(Inherited from FilterRule)
Public methodElementPasses Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
(Inherited from FilterRule)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetEvaluator Gets the evaluator that implements the test for this rule.
(Inherited from FilterNumericValueRule)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetRuleParameter Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.
(Inherited from FilterRule)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetEvaluator Sets the evaluator that implements the test for this rule.
(Inherited from FilterNumericValueRule)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also