FilterDoubleRule Class

A filter rule that operates on double-precision numeric values in a Revit project.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterDoubleRule : FilterNumericValueRule

The FilterDoubleRule type exposes the following members.

Constructors
 NameDescription
Public methodFilterDoubleRule Constructs an instance of FilterDoubleRule.
Top
Properties
 NameDescription
Public propertyEpsilon The tolerance within which two floating-point values may be considered equal.
Public propertyRuleValue The user-supplied value against which values from a Revit document will be tested.
Top
Methods
 NameDescription
Top
See Also