FilterNumericValueRule Class

Base for all classes that use a FilterNumericRuleEvaluator to perform their comparisons
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterNumericValueRule : FilterValueRule

The FilterNumericValueRule type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterRule)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from FilterRule)
Public methodElementPasses Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
(Inherited from FilterRule)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetEvaluator Gets the evaluator that implements the test for this rule.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetRuleParameter Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.
(Inherited from FilterRule)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetEvaluator Sets the evaluator that implements the test for this rule.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also