MEPBuildingConstructionSet Class

A set that contains MEPBuildingConstructions.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DB.MechanicalMEPBuildingConstructionSet

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MEPBuildingConstructionSet : APIObject, 
	IEnumerable

The MEPBuildingConstructionSet type exposes the following members.

Constructors
 NameDescription
Public methodMEPBuildingConstructionSetInitializes a new instance of the MEPBuildingConstructionSet class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the set is empty.
Public propertySizeReturns the number of MEPBuildingConstructions that are in the set.
Top
Methods
 NameDescription
Public methodClearRemoves every MEPBuildingConstruction from the set, rendering it empty.
Public methodContainsTests for the existence of a MEPBuildingConstruction within the set.
Public methodEraseRemoves a specified MEPBuildingConstruction from the set.
Public methodForwardIteratorRetrieve a forward moving iterator to the set.
Public methodGetEnumeratorRetrieve a forward moving iterator to the set.
Public methodInsertInsert the specified MEPBuildingConstruction into the set.
Public methodReverseIteratorRetrieve a backward moving iterator to the set.
Top
See Also