KeyBasedTreeEntriesLoadResults Class

This class contains the results and status information regarding an attempt to load the KeyBasedTreeEntries from an External Resource.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBKeyBasedTreeEntriesLoadResults

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class KeyBasedTreeEntriesLoadResults : IDisposable

The KeyBasedTreeEntriesLoadResults type exposes the following members.

Constructors
 NameDescription
Public methodKeyBasedTreeEntriesLoadResults Creates an empty KeyBasedTreeEntriesLoadResults.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the KeyBasedTreeEntriesLoadResults
Public methodGetFailureMessages Get all error or warnings created while attempting to load KeyBasedTreeEntries.
Public methodGetFileReadErrors Gets the names of any files which could not be read due to access errors.
Public methodGetFileSyntaxErrors Gets all the records in the key-based tree data text file that could not be parsed into KeyBasedTreeEntries.
Public methodGetKeyBasedTreeEntryErrors Gets information about KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors.
Public methodGetKeyBasedTreeEntryErrors(KeyBasedTreeEntryErrorType) Gets information about specific KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors of a particular type.
Top
Remarks

A KeyBasedTreeEntriesLoadResults object is returned by the KeynoteTable or AssemblyCodeTable API methods LoadFrom() and Reload() so that callers can determine whether the KeynoteTable or AssemblyCodeTable was updated successfully and what, if any, errors occurred.

See Also