PointLocationOnCurve Class

Defines the measurement parameters necessary to create a point at a specific location on a curve.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBPointLocationOnCurve

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PointLocationOnCurve : IDisposable

The PointLocationOnCurve type exposes the following members.

Constructors
 NameDescription
Public methodPointLocationOnCurve Constructs a new instance of a class, with given or default values, to place a point on a curve.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyMeasureFrom The location on the curve from which the measurement is taken.
Public propertyMeasurementType The measurement type.
Public propertyMeasurementValue The measurement value.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the PointLocationOnCurve
Top
Remarks
The class will store the following and provides functions to deal with them:
  • The user visible Measurement Type (driving parameter type).
  • The corresponding measurement value (driving parameter).
  • MeasureFrom that tells from where the (driving parameter) measurement is calculated.
See Also