FamilyPointPlacementReference Class

This object represents data corresponding to the placement references in a certain types of Family Instances (see examples listed below).
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBFamilyPointPlacementReference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilyPointPlacementReference : APIObject

The FamilyPointPlacementReference type exposes the following members.

Properties
 NameDescription
Public propertyLocation The location of the point.
Public propertyName The name of the corresponding reference point in the Family document.
Public propertyPointReference The reference on which the point depends on.
Top
Methods
 NameDescription
Top
Remarks
Examples of FamilyInstance objects that contain placement references are Panels and Flexible Components.
See Also