ForgeTypeId Class

This class holds a string that uniquely identifies a Forge schema.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBForgeTypeId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ForgeTypeId : IDisposable

The ForgeTypeId type exposes the following members.

Constructors
 NameDescription
Public methodForgeTypeId Constructs a ForgeTypeId holding an empty schema identifier.
Public methodForgeTypeId(String) Constructs a ForgeTypeId holding the given schema identifier.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyTypeId The schema identifier.
Top
Methods
 NameDescription
Public methodClear Sets the typeId to an empty string
Public methodDisposeReleases all resources used by the ForgeTypeId
Public methodEmpty Checks if the typeId is an empty string
Public methodEquals Determines whether this ForgeTypeId is equal to another.
(Overrides ObjectEquals(Object))
Public methodGetHashCode Returns the hash code for this ForgeTypeId
(Overrides ObjectGetHashCode)
Public methodNameEquals Returns true if the typeid string held by this ForgeTypeId is equal to that held by the given ForgeTypeId, excluding the version number. The version number of a typeid string follows a hyphen character. This function compares the typeid strings up to the first hyphen. This is the default equality comparison method for the ForgeTypeId class, used by the equality operator (==).
Public methodStrictlyEquals Returns true if the entire typeid string held by this ForgeTypeId is exactly equal to that held by the given ForgeTypeId. For the default equality comparison used by the equality operator (==), see NameEquals(ForgeTypeId).
Top
Operators
See Also