UIThemeManager Class

Manager object for the UITheme class.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIUIThemeManager

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class UIThemeManager

The UIThemeManager type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberCurrentCanvasTheme current canvas theme.
Public propertyStatic memberCurrentTheme The current overall theme which impacts the Revit frame and canvas.
Public propertyStatic memberFollowSystemColorTheme Indicate if the overall theme follows operating system color theme.
Top
Methods
 NameDescription
Public methodStatic memberGetThemeName Gets the theme name for the given theme type.
Top
See Also