IPointCloudAccess Interface

An interface that provides functionality for working with an individual Point Cloud.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IPointCloudAccess

The IPointCloudAccess type exposes the following members.

Methods
 NameDescription
Public methodCreatePointSetIterator(PointCloudFilter, ElementId) Implement this method to return an iterator for iterating over blocks of this point cloud.
Public methodCreatePointSetIterator(PointCloudFilter, Double, ElementId) Implement this method to return an iterator for iterating over blocks of this point cloud.
Public methodFree Completes the lifetime of the object providing this interface.
Public methodGetColorEncoding Returns the encoding used by points in this point cloud.
Public methodGetExtent Implement this method to returns an object that contains the bounding box of the entire point cloud, aligned to the point cloud coordinate system.
Public methodGetName Implement this method to return the name of the point cloud that will be used when Revit needs to refer to the point cloud type, e.g. in the Manage Links dialog or in the Type Properties dialog.
Public methodGetOffset Implement this method to return the offset stored in the point cloud.
Public methodGetUnitsToFeetConversionFactor Implement this method to return the conversion factor from the units of the point cloud to feet.
Public methodReadPoints Implement this method so that on successive invocations it will return distinct subsets of points which meet the criterion.
Top
Remarks

An instance of this interface is obtained from the associated point cloud engine when the engine's CreatePointCloudAccess method is called.

An instance of this class will be requested by Revit when drawing the point cloud in the view. For performance reasons, when rendering every frame Revit asks the engine to fetch the necessary points split into multiple batches. The number of batches requested depends on the view: the smaller the projection of the cloud bounding box on the screen the fewer batches Revit requests. Revit assumes that each batch contains points uniformly distributed over the visible part of the cloud ("visible" as defined by the filter). Thus, the points supplied by the engine should not be geometrically distinct (e.g. divided into multiple independent volumes, because at distant zoom levels Revit will only request a few batches and only part of the cloud will be displayed.

See Also