IPointCloudAccessCreatePointSetIterator(PointCloudFilter, ElementId) Method |
Implement this method to return an iterator for iterating over blocks of this point cloud.
Namespace: Autodesk.Revit.DB.PointCloudsAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxIPointSetIterator CreatePointSetIterator(
PointCloudFilter rFilter,
ElementId viewId
)
Function CreatePointSetIterator (
rFilter As PointCloudFilter,
viewId As ElementId
) As IPointSetIterator
IPointSetIterator^ CreatePointSetIterator(
PointCloudFilter^ rFilter,
ElementId^ viewId
)
abstract CreatePointSetIterator :
rFilter : PointCloudFilter *
viewId : ElementId -> IPointSetIterator
Parameters
- rFilter PointCloudFilter
-
The filter used to process cloud points and determine which ones lie with the target volume.
- viewId ElementId
-
The view id for the current view passed as auxiliary information to allow the
engine to optimize retrieval of points. If viewId == InvalidElementId, the
query is not for a view display operation.
Return Value
IPointSetIterator
The newly created iterator.
See Also