PromptForFamilyInstancePlacementOptions Class

This class contains options to control the behavior of interactive placement of family instances.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIPromptForFamilyInstancePlacementOptions

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PromptForFamilyInstancePlacementOptions : IDisposable

The PromptForFamilyInstancePlacementOptions type exposes the following members.

Constructors
 NameDescription
Public methodPromptForFamilyInstancePlacementOptions Creates a new PromptForFamilyInstancePlacementOptions using default options.
Public methodPromptForFamilyInstancePlacementOptions(PromptForFamilyInstancePlacementOptions) Creates a copy of an existing options object.
Top
Properties
 NameDescription
Public propertyFaceBasedPlacementType The placement type to be used if prompting to place an instance of a face-based family. This option is ignored if placing a non-face-based family. If placing a face-based family, Default is an acceptable value, but will correspond to the first available selection in the user interface.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyPlaceAirTerminalOnDuct If true, when placing an air terminal, the terminal will be placed directly on the duct without fittings. If fase, the terminal will be placed with generated fittings.
Public propertySketchGalleryOptions The sketch option provided when promt to place a family instance.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the PromptForFamilyInstancePlacementOptions
Top
See Also