PromptForFamilyInstancePlacementOptionsFaceBasedPlacementType Property |
The placement type to be used if prompting to place an instance of a face-based family.
This option is ignored if placing a non-face-based family. If placing a face-based family, Default is an acceptable value, but will correspond to the first available selection in the user interface.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FaceBasedPlacementType FaceBasedPlacementType { get; set; }
Public Property FaceBasedPlacementType As FaceBasedPlacementType
Get
Set
public:
property FaceBasedPlacementType FaceBasedPlacementType {
FaceBasedPlacementType get ();
void set (FaceBasedPlacementType value);
}
member FaceBasedPlacementType : FaceBasedPlacementType with get, set
Property Value
FaceBasedPlacementType
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
See Also