MaterialNode Class

This class represents a change of material during a model-exporting process.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRenderNode
    Autodesk.Revit.DBMaterialNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MaterialNode : RenderNode

The MaterialNode type exposes the following members.

Properties
 NameDescription
Public propertyColor The color the material is being rendered at
Public propertyGlossiness The level of glossiness of the material
Public propertyHasOverriddenAppearance Identifies if the default rendering appearance the material has is being overridden.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RenderNode)
Public propertyMaterialId The Id of the element assocated with this material in the model.
Public propertyNodeName A readable name of the output node.
(Inherited from RenderNode)
Public propertySmoothness The level of smoothness of the material.
Public propertyThumbnailFile The path if a file that contains a thumbnail image of the material.
Public propertyTransparency The value of transparency the material is being rendered with
Top
Methods
 NameDescription
Public methodDispose
(Inherited from RenderNode)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetAppearance Appearance properties associated with the material.
Public methodGetAppearanceOverride Returns appearance properties that override the preset appearance of the material.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks

Output nodes following this node are to be assumed using the material. The material remains in effect until another material node is sent to the output.

See also: OnMaterial(MaterialNode).

See Also