MaterialNodeGetAppearance Method |
Appearance properties associated with the material.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Asset GetAppearance()
Public Function GetAppearance As Asset
public:
Asset^ GetAppearance()
member GetAppearance : unit -> Asset
Return Value
Asset
An instance of a rendering material asset
Remarks
Properties and attributes of the material's appearance
can be accessed using the standard interface of the Asset class.
The structure of the properties, including their types and names
is proprietary and as such it is not always useful to anyone who
is not familiar with the particular schema. Also, the structure
is not standardized and may change over time, therefore it is not
recommended relaying on any appearance property to be present.
See Also