RepeatingReferenceSource Class

Represents a collection of repeating references.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRepeatingReferenceSource

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RepeatingReferenceSource : IDisposable

The RepeatingReferenceSource type exposes the following members.

Properties
 NameDescription
Public propertyDimensionCount The dimension count of the repeating reference array.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the RepeatingReferenceSource
Public methodGetBounds Returns information about the boundaries of the repeating reference array.
Public methodStatic memberGetDefaultRepeatingReferenceSource Returns the default repeating reference source for a given element.
Public methodGetReference Returns an individual repeating reference given by coordinates in the array, or if there is no reference at the coordinates (for example if there is a hole in a divided surface.)
Public methodStatic memberHasRepeatingReferenceSource Determines whether an element has any repeating reference sources that can be used when creating component repeaters.
Top
Remarks

The RepeatingReferenceSource class is the building block for setting up component repeaters. Repeating references are arranged in zero, one or two dimensional arrays. The RepeatingReferenceSource class represents this array of references and provides access to individual repeating references.

Note that there may be gaps in the array (for example a repeating reference source formed by a divided surface with holes, or is non-rectangular surface.)

Repeating reference sources are a property of an element. Only point elements, divided paths and divided surface elements support repeating reference sources. These element respectively have 0, 1 and 2 dimensional repeating references. Use the HasRepeatingReferenceSource() method to query whether an element supports repeating reference sources and the GetDefaultRepeatingReferenceSource() method to obtain a repeating reference source from a given element.

See the ComponentRepeater and ComponentRepeaterSlot classes for more information.

See Also