RepeatingReferenceSourceGetDefaultRepeatingReferenceSource Method |
Returns the default repeating reference source for a given element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static RepeatingReferenceSource GetDefaultRepeatingReferenceSource(
Document document,
ElementId elementId
)
Public Shared Function GetDefaultRepeatingReferenceSource (
document As Document,
elementId As ElementId
) As RepeatingReferenceSource
public:
static RepeatingReferenceSource^ GetDefaultRepeatingReferenceSource(
Document^ document,
ElementId^ elementId
)
static member GetDefaultRepeatingReferenceSource :
document : Document *
elementId : ElementId -> RepeatingReferenceSource
Parameters
- document Document
-
The document that contains the element.
- elementId ElementId
-
The id of the element.
Return Value
RepeatingReferenceSource
The default repeating reference source of the given element.
ExceptionsException | Condition |
---|
ArgumentException |
The element elementId does not exist in the document
-or-
The element does not have any repeating reference sources.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
The element must support repeating references. Use HasRepeatingReferenceSource() to find out whether an element has any repeating references.
See Also